summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGeorgi Kodinov <joro@sun.com>2009-05-27 17:09:09 +0300
committerGeorgi Kodinov <joro@sun.com>2009-05-27 17:09:09 +0300
commitf1463061b281916d81e5a2838101df88bf550df2 (patch)
tree9a99bd03c8fb307d589f19a397f90d1153363d54 /CMakeLists.txt
parentf54beb2dccb921296a4c0bec1aa45e5dd6e53a69 (diff)
parentf82b2851c3d8d567b5973614a489a0b1d68fa400 (diff)
downloadmariadb-git-f1463061b281916d81e5a2838101df88bf550df2.tar.gz
automerge
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f66453ef492..91c3a804eea 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -32,6 +32,10 @@ SET(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} -DFORCE_INIT_OF_VARS")
# Note that some engines are always compiled in, MyISAM, MyISAMMRG, HEAP
+IF(WITH_COMMUNITY_FEATURES)
+ ADD_DEFINITIONS(-DENABLED_PROFILING -DCOMMUNITY_SERVER)
+ENDIF(WITH_COMMUNITY_FEATURES)
+
IF(WITH_ARCHIVE_STORAGE_ENGINE)
ADD_DEFINITIONS(-DHAVE_ARCHIVE_DB)
ENDIF(WITH_ARCHIVE_STORAGE_ENGINE)