summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorunknown <iggy@rolltop.ignatz42.dyndns.org>2006-09-28 15:18:33 -0400
committerunknown <iggy@rolltop.ignatz42.dyndns.org>2006-09-28 15:18:33 -0400
commit69aa7b40c22994fce94029f11fcdc5e1c7dabcaf (patch)
tree990ddb541b9830fa9f5c72610490e1c97332282c /CMakeLists.txt
parenta9be99af8371a82be482b9a1b711da188008bff3 (diff)
downloadmariadb-git-69aa7b40c22994fce94029f11fcdc5e1c7dabcaf.tar.gz
Bug#22224: Windows build depends on ib_config.h
This change has already been made to 5.1. CMakeLists.txt: Removed dependancy on ib_config.h Added conditionals for InnoDB and BDB directories. innobase/include/univ.i: ib_config.h is not required for Windows.
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fd780ec6a13..8058f615f7c 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -29,8 +29,6 @@ IF (WITH_MYISAMMRG_STORAGE_ENGINE)
ENDIF (WITH_MYISAMMRG_STORAGE_ENGINE)
IF(WITH_INNOBASE_STORAGE_ENGINE)
- CONFIGURE_FILE(${CMAKE_SOURCE_DIR}/innobase/ib_config.h.in
- ${CMAKE_SOURCE_DIR}/innobase/ib_config.h @ONLY)
ADD_DEFINITIONS(-D HAVE_INNOBASE_DB)
ADD_DEFINITIONS(-D WITH_INNOBASE_STORAGE_ENGINE)
SET (mysql_plugin_defs "${mysql_plugin_defs},builtin_innobase_plugin")
@@ -123,8 +121,12 @@ ADD_SUBDIRECTORY(heap)
ADD_SUBDIRECTORY(myisam)
ADD_SUBDIRECTORY(myisammrg)
ADD_SUBDIRECTORY(client)
+IF(WITH_BERKELEY_STORAGE_ENGINE)
ADD_SUBDIRECTORY(bdb)
+ENDIF(WITH_BERKELEY_STORAGE_ENGINE)
+IF(WITH_INNOBASE_STORAGE_ENGINE)
ADD_SUBDIRECTORY(innobase)
+ENDIF(WITH_INNOBASE_STORAGE_ENGINE)
ADD_SUBDIRECTORY(sql)
ADD_SUBDIRECTORY(sql/examples)
ADD_SUBDIRECTORY(server-tools/instance-manager)