summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSatya B <satya.bn@sun.com>2009-06-05 17:03:33 +0530
committerSatya B <satya.bn@sun.com>2009-06-05 17:03:33 +0530
commitb6312995f1eb1478c8af30452c99e9b94b5f8185 (patch)
tree9f2ad71c11b05abfb2facd6e42132e9f1a218ec6 /CMakeLists.txt
parent797cc5a739faf50076d7b69f3e5300a9f6bc7dad (diff)
parent5cbb9317ad48106ed73b62408927b8a7678d0554 (diff)
downloadmariadb-git-b6312995f1eb1478c8af30452c99e9b94b5f8185.tar.gz
merge from mysql-5.1-innodb_plugin branch.
change tree name to 'mysql-5.1-innodb_plugin'
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7c173c9cb49..e4dc16040a7 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -47,6 +47,10 @@ SET(WITH_MYISAMMRG_STORAGE_ENGINE TRUE)
ADD_DEFINITIONS(-DWITH_MYISAMMRG_STORAGE_ENGINE)
SET (mysql_plugin_defs "${mysql_plugin_defs},builtin_myisammrg_plugin")
+IF(WITH_COMMUNITY_FEATURES)
+ ADD_DEFINITIONS(-DENABLED_PROFILING -DCOMMUNITY_SERVER)
+ENDIF(WITH_COMMUNITY_FEATURES)
+
IF(WITH_ARCHIVE_STORAGE_ENGINE)
ADD_DEFINITIONS(-DWITH_ARCHIVE_STORAGE_ENGINE)
SET (mysql_plugin_defs "${mysql_plugin_defs},builtin_archive_plugin")