summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authoriggy@alf.(none) <>2008-02-27 16:22:10 -0500
committeriggy@alf.(none) <>2008-02-27 16:22:10 -0500
commit1c0302ee795f46618b25c25d73c0534d55802855 (patch)
tree741bf1b14b1800036877bde5cf3f0a328374c2d9 /CMakeLists.txt
parent45442d08d4df211a4f42b6f8437dba4014b39759 (diff)
parentefacf8caa6ffeeb636d097c5efeb94c1873e8239 (diff)
downloadmariadb-git-1c0302ee795f46618b25c25d73c0534d55802855.tar.gz
Merge alf.(none):/src/macro_bugs/my50-macro_bugs
into alf.(none):/src/macro_bugs/my51-macro_bugs
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 341f8d08df2..1fff37c1186 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -153,6 +153,14 @@ IF(WIN32)
ADD_DEFINITIONS("-D_WINDOWS -D__WIN__ -D_CRT_SECURE_NO_DEPRECATE")
ENDIF(WIN32)
+# This definition is necessary to work around a bug with Intellisense described
+# here: http://tinyurl.com/2cb428. Syntax highlighting is important for proper
+# debugger functionality.
+IF(CMAKE_SIZEOF_VOID_P MATCHES 8)
+ MESSAGE(STATUS "Detected 64-bit platform.")
+ ADD_DEFINITIONS("-D_WIN64")
+ENDIF(CMAKE_SIZEOF_VOID_P MATCHES 8)
+
IF(EMBED_MANIFESTS)
# Search for the tools (mt, makecat, signtool) necessary for embedding
# manifests and signing executables with the MySQL AB authenticode cert.