summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVladislav Vaintroub <wlad@montyprogram.com>2010-12-01 21:37:03 +0100
committerVladislav Vaintroub <wlad@montyprogram.com>2010-12-01 21:37:03 +0100
commitc87923dc2d3f6b5e96d51957937be8a5b343ab51 (patch)
treeb2aa4348ad143b02bb0c44e1c3adee989bfd4a85 /CMakeLists.txt
parent6f279f40145624c1ffab06c63521f96ce4ac3a02 (diff)
downloadmariadb-git-c87923dc2d3f6b5e96d51957937be8a5b343ab51.tar.gz
Make maria 5.1 compilable on Visual Studio 2010 and remove Windows warnings
- Remove all mentioning of /MAP /MAPINFO link options (does not work in VS2010). Remove map files from packaging. - Fix warning about ETIMEDOUT being redefined. - Fix warning about FSP_EXTENT_SIZE in xtradb (32/64 bit right shift mismatch) - Silence warnings coming from generated code (flex/bison) in xtradb/innodb_plugin. - Be nice to people without cygwin (me) and add win/configure-mariadb.bat with options suitable for quick compilation, e.g no embedded
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5cfe5dc8319..3b8d833e19a 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -116,7 +116,6 @@ IF(MSVC)
STRING(REPLACE "/MDd" "/MTd" CMAKE_CXX_FLAGS_DEBUG_INIT ${CMAKE_CXX_FLAGS_DEBUG_INIT})
# generate map files, set stack size (see bug#20815)
- SET(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} /MAP /MAPINFO:EXPORTS")
SET(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} /STACK:1048576")
# remove support for Exception handling