summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBo Thorsen <bo@askmonty.org>2010-06-30 14:10:40 +0200
committerBo Thorsen <bo@askmonty.org>2010-06-30 14:10:40 +0200
commitccdbcaeb57d203cc7b16965f0216e3e96a850e56 (patch)
tree2aea3577b5f7a9e2b2ae85672abe3c6ea943bb52 /CMakeLists.txt
parente4379c5131233862f085ed49bea812e2f7cfd1a4 (diff)
downloadmariadb-git-ccdbcaeb57d203cc7b16965f0216e3e96a850e56.tar.gz
Install MariaDB as a service with the installer
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cc13e198294..5cfe5dc8319 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -342,6 +342,9 @@ SET(CPACK_PACKAGE_DESCRIPTION_SUMMARY "MariaDB")
SET(CPACK_RESOURCE_FILE_LICENSE ${CMAKE_SOURCE_DIR}/COPYING)
SET(CPACK_GENERATOR NSIS)
+# Use our own NSIS template
+set(CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/win/cmake" ${CMAKE_MODULE_PATH})
+
# Installer components and grouping
SET(CPACK_COMPONENT_GROUP_SERVER_DESCRIPTION "The files necessary for running the MariaDB server.")
SET(CPACK_COMPONENT_GROUP_DEVELOPMENT_DESCRIPTION "Files used in development on the MariaDB server.")