summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorholyfoot/hf@mysql.com/hfmain.(none) <>2007-04-29 18:42:50 +0500
committerholyfoot/hf@mysql.com/hfmain.(none) <>2007-04-29 18:42:50 +0500
commite2f6bd86b40076a8b7f6f6222f60febb49991b4c (patch)
treecc7620ed1a2c650710f867868996b3131a503f1e /CMakeLists.txt
parentfa32db5f88da1b4970aaa9890b92c89479954ae4 (diff)
parent90864c2874917bca8794b71981c57263368b573a (diff)
downloadmariadb-git-e2f6bd86b40076a8b7f6f6222f60febb49991b4c.tar.gz
Merge bk@192.168.21.1:mysql-5.0
into mysql.com:/d2/hf/mrg/mysql-5.0-opt
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fcbd3f4e4bd..68238ea157c 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -26,6 +26,10 @@ ADD_DEFINITIONS(-D WITH_MYISAM_STORAGE_ENGINE)
ADD_DEFINITIONS(-D CMAKE_BUILD)
ADD_DEFINITIONS(-D HAVE_YASSL)
+# Set debug options
+SET(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} -DFORCE_INIT_OF_VARS")
+SET(CMAKE_CXX_FLAGS_RELWITHDEBINFO "${CMAKE_CXX_FLAGS_RELWITHDEBINFO} -DFORCE_INIT_OF_VARS")
+
SET (mysql_plugin_defs "${mysql_plugin_defs},builtin_myisam_plugin")