summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorunknown <georg@lmy002.wdf.sap.corp>2006-08-31 19:52:42 +0200
committerunknown <georg@lmy002.wdf.sap.corp>2006-08-31 19:52:42 +0200
commit8f4477281eb5f110094927abe7dabd67c8525fc5 (patch)
tree1a7d7e96d4dcd302dbe513ad50a16ea05cb7ed16 /CMakeLists.txt
parent085446b8c8de9154be2673efd7c8676ececd83ff (diff)
downloadmariadb-git-8f4477281eb5f110094927abe7dabd67c8525fc5.tar.gz
Additional files for cmake support
CMakeLists.txt: New BitKeeper file ``CMakeLists.txt'' bdb/CMakeLists.txt: New BitKeeper file ``bdb/CMakeLists.txt'' client/CMakeLists.txt: New BitKeeper file ``client/CMakeLists.txt'' dbug/CMakeLists.txt: New BitKeeper file ``dbug/CMakeLists.txt'' extra/CMakeLists.txt: New BitKeeper file ``extra/CMakeLists.txt'' extra/yassl/CMakeLists.txt: New BitKeeper file ``extra/yassl/CMakeLists.txt'' extra/yassl/taocrypt/CMakeLists.txt: New BitKeeper file ``extra/yassl/taocrypt/CMakeLists.txt'' heap/CMakeLists.txt: New BitKeeper file ``heap/CMakeLists.txt'' innobase/CMakeLists.txt: New BitKeeper file ``innobase/CMakeLists.txt'' libmysql/CMakeLists.txt: New BitKeeper file ``libmysql/CMakeLists.txt'' myisam/CMakeLists.txt: New BitKeeper file ``myisam/CMakeLists.txt'' myisammrg/CMakeLists.txt: New BitKeeper file ``myisammrg/CMakeLists.txt'' mysys/CMakeLists.txt: New BitKeeper file ``mysys/CMakeLists.txt'' regex/CMakeLists.txt: New BitKeeper file ``regex/CMakeLists.txt'' server-tools/CMakeLists.txt: New BitKeeper file ``server-tools/CMakeLists.txt'' server-tools/instance-manager/CMakeLists.txt: New BitKeeper file ``server-tools/instance-manager/CMakeLists.txt'' sql/CMakeLists.txt: New BitKeeper file ``sql/CMakeLists.txt'' sql/examples/CMakeLists.txt: New BitKeeper file ``sql/examples/CMakeLists.txt'' strings/CMakeLists.txt: New BitKeeper file ``strings/CMakeLists.txt'' tests/CMakeLists.txt: New BitKeeper file ``tests/CMakeLists.txt'' vio/CMakeLists.txt: New BitKeeper file ``vio/CMakeLists.txt'' win/Makefile.am: New BitKeeper file ``win/Makefile.am'' win/README: New BitKeeper file ``win/README'' win/build-vs71.bat: New BitKeeper file ``win/build-vs71.bat'' win/build-vs8.bat: New BitKeeper file ``win/build-vs8.bat'' win/build-vs8_x64.bat: New BitKeeper file ``win/build-vs8_x64.bat'' win/configure.js: New BitKeeper file ``win/configure.js'' zlib/CMakeLists.txt: New BitKeeper file ``zlib/CMakeLists.txt''
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt132
1 files changed, 132 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100755
index 00000000000..fd780ec6a13
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,132 @@
+PROJECT(MySql)
+
+# This reads user configuration, generated by configure.js.
+INCLUDE(win/configure.data)
+
+CONFIGURE_FILE(${CMAKE_SOURCE_DIR}/include/mysql_version.h.in
+ ${CMAKE_SOURCE_DIR}/include/mysql_version.h @ONLY)
+
+# Set standard options
+ADD_DEFINITIONS(-D WITH_MYISAM_STORAGE_ENGINE)
+ADD_DEFINITIONS(-D CMAKE_BUILD)
+ADD_DEFINITIONS(-D HAVE_YASSL)
+
+SET (mysql_plugin_defs "${mysql_plugin_defs},builtin_myisam_plugin")
+
+
+IF(WITH_ARCHIVE_STORAGE_ENGINE)
+ ADD_DEFINITIONS(-D HAVE_ARCHIVE_DB)
+ENDIF(WITH_ARCHIVE_STORAGE_ENGINE)
+
+IF (WITH_HEAP_STORAGE_ENGINE)
+ ADD_DEFINITIONS(-D WITH_HEAP_STORAGE_ENGINE)
+ SET (mysql_plugin_defs "${mysql_plugin_defs},builtin_heap_plugin")
+ENDIF (WITH_HEAP_STORAGE_ENGINE)
+
+IF (WITH_MYISAMMRG_STORAGE_ENGINE)
+ ADD_DEFINITIONS(-D WITH_MYISAMMRG_STORAGE_ENGINE)
+ SET (mysql_plugin_defs "${mysql_plugin_defs},builtin_myisammrg_plugin")
+ENDIF (WITH_MYISAMMRG_STORAGE_ENGINE)
+
+IF(WITH_INNOBASE_STORAGE_ENGINE)
+ CONFIGURE_FILE(${CMAKE_SOURCE_DIR}/innobase/ib_config.h.in
+ ${CMAKE_SOURCE_DIR}/innobase/ib_config.h @ONLY)
+ ADD_DEFINITIONS(-D HAVE_INNOBASE_DB)
+ ADD_DEFINITIONS(-D WITH_INNOBASE_STORAGE_ENGINE)
+ SET (mysql_plugin_defs "${mysql_plugin_defs},builtin_innobase_plugin")
+ENDIF(WITH_INNOBASE_STORAGE_ENGINE)
+
+IF(WITH_FEDERATED_STORAGE_ENGINE)
+ ADD_DEFINITIONS(-D HAVE_FEDERATED_DB)
+ ADD_DEFINITIONS(-D WITH_FEDERATED_STORAGE_ENGINE)
+ SET (mysql_plugin_defs "${mysql_plugin_defs},builtin_federated_plugin")
+ENDIF(WITH_FEDERATED_STORAGE_ENGINE)
+
+IF(WITH_BERKELEY_STORAGE_ENGINE)
+ ADD_DEFINITIONS(-D HAVE_BERKELEY_DB)
+ ADD_DEFINITIONS(-D WITH_BERKELEY_STORAGE_ENGINE)
+ SET (mysql_plugin_defs "${mysql_plugin_defs},builtin_berkeley_plugin")
+ENDIF(WITH_BERKELEY_STORAGE_ENGINE)
+
+IF (WITH_BLACKHOLE_STORAGE_ENGINE)
+ ADD_DEFINITIONS(-D HAVE_BLACKHOLE_DB)
+ENDIF (WITH_BLACKHOLE_STORAGE_ENGINE)
+
+SET(localstatedir "C:\\mysql\\data")
+CONFIGURE_FILE(${CMAKE_SOURCE_DIR}/support-files/my-huge.cnf.sh
+ ${CMAKE_SOURCE_DIR}/support-files/my-huge.ini @ONLY)
+CONFIGURE_FILE(${CMAKE_SOURCE_DIR}/support-files/my-innodb-heavy-4G.cnf.sh
+ ${CMAKE_SOURCE_DIR}/support-files/my-innodb-heavy-4G.ini @ONLY)
+CONFIGURE_FILE(${CMAKE_SOURCE_DIR}/support-files/my-large.cnf.sh
+ ${CMAKE_SOURCE_DIR}/support-files/my-large.ini @ONLY)
+CONFIGURE_FILE(${CMAKE_SOURCE_DIR}/support-files/my-medium.cnf.sh
+ ${CMAKE_SOURCE_DIR}/support-files/my-medium.ini @ONLY)
+CONFIGURE_FILE(${CMAKE_SOURCE_DIR}/support-files/my-small.cnf.sh
+ ${CMAKE_SOURCE_DIR}/support-files/my-small.ini @ONLY)
+
+IF(__NT__)
+ ADD_DEFINITIONS(-D __NT__)
+ENDIF(__NT__)
+IF(CYBOZU)
+ ADD_DEFINITIONS(-D CYBOZU)
+ENDIF(CYBOZU)
+
+# in some places we use DBUG_OFF
+SET(CMAKE_CXX_FLAGS_RELEASE "${CMAKE_CXX_FLAGS_RELEASE} -D DBUG_OFF")
+SET(CMAKE_C_FLAGS_RELEASE "${CMAKE_C_FLAGS_RELEASE} -D DBUG_OFF")
+
+IF(CMAKE_GENERATOR MATCHES "Visual Studio 8")
+ SET(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} /wd4996")
+ SET(CMAKE_CXX_FLAGS_RELEASE "${CMAKE_CXX_FLAGS_RELEASE} /wd4996")
+ SET(CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} /wd4996")
+ SET(CMAKE_C_FLAGS_RELEASE "${CMAKE_C_FLAGS_RELEASE} /wd4996")
+ENDIF(CMAKE_GENERATOR MATCHES "Visual Studio 8")
+
+IF(CMAKE_GENERATOR MATCHES "Visual Studio 7" OR
+ CMAKE_GENERATOR MATCHES "Visual Studio 8")
+ # replace /MDd with /MTd
+ STRING(REPLACE "/MDd" "/MTd" CMAKE_CXX_FLAGS_DEBUG_INIT
+ ${CMAKE_CXX_FLAGS_DEBUG_INIT})
+ STRING(REPLACE "/MDd" "/MTd" CMAKE_C_FLAGS_DEBUG_INIT
+ ${CMAKE_C_FLAGS_DEBUG_INIT})
+ STRING(REPLACE "/MD" "/MT" CMAKE_C_FLAGS_RELEASE
+ ${CMAKE_C_FLAGS_RELEASE})
+ STRING(REPLACE "/MDd" "/MTd" CMAKE_C_FLAGS_DEBUG
+ ${CMAKE_C_FLAGS_DEBUG})
+ STRING(REPLACE "/MD" "/MT" CMAKE_CXX_FLAGS_RELEASE
+ ${CMAKE_CXX_FLAGS_RELEASE})
+ STRING(REPLACE "/MDd" "/MTd" CMAKE_CXX_FLAGS_DEBUG
+ ${CMAKE_CXX_FLAGS_DEBUG})
+
+ # remove support for Exception handling
+ STRING(REPLACE "/GX" "" CMAKE_CXX_FLAGS ${CMAKE_CXX_FLAGS})
+ STRING(REPLACE "/EHsc" "" CMAKE_CXX_FLAGS ${CMAKE_CXX_FLAGS})
+ STRING(REPLACE "/EHsc" "" CMAKE_CXX_FLAGS_INIT
+ ${CMAKE_CXX_FLAGS_INIT})
+ STRING(REPLACE "/EHsc" "" CMAKE_CXX_FLAGS_DEBUG_INIT
+ ${CMAKE_CXX_FLAGS_DEBUG_INIT})
+ENDIF(CMAKE_GENERATOR MATCHES "Visual Studio 7" OR
+ CMAKE_GENERATOR MATCHES "Visual Studio 8")
+
+ADD_DEFINITIONS("-D_WINDOWS -D__WIN__ -D _CRT_SECURE_NO_DEPRECATE")
+
+ADD_SUBDIRECTORY(vio)
+ADD_SUBDIRECTORY(dbug)
+ADD_SUBDIRECTORY(strings)
+ADD_SUBDIRECTORY(regex)
+ADD_SUBDIRECTORY(mysys)
+ADD_SUBDIRECTORY(extra/yassl)
+ADD_SUBDIRECTORY(extra/yassl/taocrypt)
+ADD_SUBDIRECTORY(extra)
+ADD_SUBDIRECTORY(zlib)
+ADD_SUBDIRECTORY(heap)
+ADD_SUBDIRECTORY(myisam)
+ADD_SUBDIRECTORY(myisammrg)
+ADD_SUBDIRECTORY(client)
+ADD_SUBDIRECTORY(bdb)
+ADD_SUBDIRECTORY(innobase)
+ADD_SUBDIRECTORY(sql)
+ADD_SUBDIRECTORY(sql/examples)
+ADD_SUBDIRECTORY(server-tools/instance-manager)
+ADD_SUBDIRECTORY(libmysql)
+ADD_SUBDIRECTORY(tests)