summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVicențiu Ciorbaru <vicentiu@mariadb.org>2018-06-10 17:16:27 +0300
committerVicențiu Ciorbaru <vicentiu@mariadb.org>2018-06-10 17:16:27 +0300
commit3ead95118098340f7fe36e34e1690839d183db1e (patch)
tree90dcbcf7f6793609af78220fd45bf7337f00ff62 /CMakeLists.txt
parent7053e26e1869962ef473043686996f40ac0fb88c (diff)
parent1d43f71c7b4c39a6fd196c104b5ebafb65376199 (diff)
downloadmariadb-git-3ead95118098340f7fe36e34e1690839d183db1e.tar.gz
Merge branch '5.5' into 10.0
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 11874650d18..c70ad8b035f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -378,6 +378,10 @@ INCLUDE(maintainer)
IF(WITH_UNIT_TESTS)
ENABLE_TESTING()
+ # This is the only instance where ADD_TEST should be used,
+ # to make sure that make test will run MTR,
+ # use MY_ADD_TEST macro to add other tests
+ ADD_TEST(NAME MTR COMMAND ./mysql-test-run WORKING_DIRECTORY "mysql-test")
ADD_SUBDIRECTORY(unittest/mytap)
ADD_SUBDIRECTORY(unittest/strings)
ADD_SUBDIRECTORY(unittest/examples)