summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDavi Arnaut <davi.arnaut@oracle.com>2010-09-24 10:03:17 -0300
committerDavi Arnaut <davi.arnaut@oracle.com>2010-09-24 10:03:17 -0300
commit2044c807452680edc9481dcdcce3976923fd33a4 (patch)
tree9eb89cafd3630a30b536d169a249e8e5ad05b1a1 /CMakeLists.txt
parente1b299ed02b04c372182766103a23b4b5a2955bd (diff)
parent77a0ae9a9a1ca649b6b317587cabe0925d2441aa (diff)
downloadmariadb-git-2044c807452680edc9481dcdcce3976923fd33a4.tar.gz
Merge of mysql-5.1-bugteam into mysql-5.5-merge.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index eecfa422bf6..5eddad4ad15 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -112,7 +112,8 @@ OPTION(MYSQL_MAINTAINER_MODE "MySQL maintainer-specific development environment"
# Whether the maintainer mode should be enabled.
IF(MYSQL_MAINTAINER_MODE)
IF(CMAKE_COMPILER_IS_GNUCC)
- SET(MY_MAINTAINER_C_WARNINGS "-Wall -Wextra -Wunused -Wwrite-strings -Werror"
+ SET(MY_MAINTAINER_C_WARNINGS
+ "-Wall -Wextra -Wunused -Wwrite-strings -Wno-strict-aliasing -Werror"
CACHE STRING "C warning options used in maintainer builds.")
ENDIF()
IF(CMAKE_COMPILER_IS_GNUCXX)