summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorgkodinov/kgeorge@magare.gmz <>2007-04-23 17:15:51 +0300
committergkodinov/kgeorge@magare.gmz <>2007-04-23 17:15:51 +0300
commit975815280aba9f16d6bf0eeb92b561a766bc3d04 (patch)
treee1e2c8962687ebeb74a223bd271b6c25ad1c8f36 /CMakeLists.txt
parent83fff262619c49759e0598eb00e08a723684fc5f (diff)
downloadmariadb-git-975815280aba9f16d6bf0eeb92b561a766bc3d04.tar.gz
Bug #27811:
FORCE_INIT_OF_VARS was not defined for the debug builds on Windows. This caused LINT_INIT macro to be defined as NOP and this triggers false alarms about use of uninitialized with the runtime libs of some Visual Studio versions. Fixed by defining FORCE_INIT_OF_VARS to match the state of the Windows
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3a286071bb0..b93b3e0db27 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -26,6 +26,10 @@ ADD_DEFINITIONS(-D WITH_MYISAM_STORAGE_ENGINE)
ADD_DEFINITIONS(-D CMAKE_BUILD)
ADD_DEFINITIONS(-D HAVE_YASSL)
+# Set debug options
+SET(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} -DFORCE_INIT_OF_VARS")
+SET(CMAKE_CXX_FLAGS_RELWITHDEBINFO "${CMAKE_CXX_FLAGS_RELWITHDEBINFO} -DFORCE_INIT_OF_VARS")
+
SET (mysql_plugin_defs "${mysql_plugin_defs},builtin_myisam_plugin")