summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSergei Golubchik <sergii@pisem.net>2013-08-30 10:56:26 +0200
committerSergei Golubchik <sergii@pisem.net>2013-08-30 10:56:26 +0200
commitcd92bc38a7fd9442f668fbb1eed1634b04cc6d4d (patch)
tree5b913cfddbc37f980b2bcb094dd35b5166b17566 /CMakeLists.txt
parent253366e7762ef73145d3a73bf3212083522aa259 (diff)
downloadmariadb-git-cd92bc38a7fd9442f668fbb1eed1634b04cc6d4d.tar.gz
start using jemalloc
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 40062957372..9b8c9defeb7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -144,6 +144,7 @@ INCLUDE(ssl)
INCLUDE(readline)
INCLUDE(libutils)
INCLUDE(dtrace)
+INCLUDE(jemalloc)
INCLUDE(ctest)
INCLUDE(plugin)
INCLUDE(install_macros)
@@ -263,6 +264,8 @@ MYSQL_CHECK_SSL()
# Add readline or libedit.
MYSQL_CHECK_READLINE()
+CHECK_JEMALLOC()
+
#
# Setup maintainer mode options by the end. Platform checks are
# not run with the warning options as to not perturb fragile checks