summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSergei Golubchik <serg@mariadb.org>2015-11-20 13:41:22 +0100
committerSergei Golubchik <serg@mariadb.org>2015-11-23 16:02:56 +0100
commit4f84d9ce888864bd4fd3863ace3df33a64236d6b (patch)
tree56056d51ecc41ff13b888c505ee469ab7235e84a /CMakeLists.txt
parent061f84ab86ce8a9df6c7bb364a706c19e8a4e139 (diff)
downloadmariadb-git-4f84d9ce888864bd4fd3863ace3df33a64236d6b.tar.gz
cmake: MYSQL_PARSE_ARGUMENTS -> CMAKE_PARSE_ARGUMENTS
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 1 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3ef10407c24..6954b45f56d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,11 +14,7 @@
# along with this program; if not, write to the Free Software
# Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
-CMAKE_MINIMUM_REQUIRED(VERSION 2.6)
-# Avoid warnings in higher versions
-if("${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION}" GREATER 2.6)
- CMAKE_POLICY(VERSION 2.8)
-endif()
+CMAKE_MINIMUM_REQUIRED(VERSION 2.8.3)
# explicitly set the policy to OLD
# (cannot use NEW, not everyone is on cmake-2.8.12 yet)