summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBo Thorsen <bo@askmonty.org>2010-06-28 16:41:43 +0200
committerBo Thorsen <bo@askmonty.org>2010-06-28 16:41:43 +0200
commit3a2e38aa2829eee3b4b66bd51e43c4be1c11b36b (patch)
treee4df3729a5bcad418b437f3d69cae82dd3d94708 /CMakeLists.txt
parent6a6d87186a5bf74bc4efd3a5bdb2592107164cd7 (diff)
downloadmariadb-git-3a2e38aa2829eee3b4b66bd51e43c4be1c11b36b.tar.gz
Install the files for the embedded server
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 425039ea062..7a938e73c09 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -355,13 +355,16 @@ SET(CPACK_COMPONENT_HEADERS_DESCRIPTION "Header files for development on MariaDB
SET(CPACK_COMPONENT_HEADERS_DEPENDS runtime)
SET(CPACK_COMPONENT_HEADERS_GROUP "Development")
SET(CPACK_COMPONENT_HEADERS_INSTALL_TYPES Development)
+SET(CPACK_COMPONENT_EMBEDDED_DISPLAY_NAME "Embedded")
+SET(CPACK_COMPONENT_EMBEDDED_DESCRIPTION "Files for embedding MariaDB in other projects.")
+SET(CPACK_COMPONENT_EMBEDDED_DEPENDS headers)
+SET(CPACK_COMPONENT_EMBEDDED_GROUP "Development")
+SET(CPACK_COMPONENT_EMBEDDED_INSTALL_TYPES Development)
SET(CPACK_COMPONENT_SCRIPTS_DISPLAY_NAME "Server scripts")
SET(CPACK_COMPONENT_SCRIPTS_DESCRIPTION "SQL and Perl scripts to control and modify the server. You need a perl installation for some of these to work.")
SET(CPACK_COMPONENT_SCRIPTS_DEPENDS runtime)
SET(CPACK_COMPONENT_SCRIPTS_GROUP "Server")
SET(CPACK_COMPONENT_SCRIPTS_INSTALL_TYPES Normal Development)
-# TODO: Add debug files
-# TODO: Add embedded server files
# TODO: Add test files
# TODO: Add sql-bench