summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorOleksandr Byelkin <sanja@mariadb.com>2018-07-25 22:24:40 +0200
committerOleksandr Byelkin <sanja@mariadb.com>2018-07-25 22:24:40 +0200
commitcb5952b5060d089c021808fe1f1cf13f7eb88423 (patch)
tree1e4678bd3b899428428b4f7980b92fade8e57f62 /CMakeLists.txt
parent57cde8ccd19675dc98e3cbacf0ef5c72cb188e49 (diff)
parent9fbe360e9f7d41d169eb5abed22dc15f26f6c749 (diff)
downloadmariadb-git-cb5952b5060d089c021808fe1f1cf13f7eb88423.tar.gz
Merge branch '10.0' into bb-10.1-merge-sanja
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8d2efac89cb..0b48ca20485 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -179,6 +179,12 @@ ENDIF()
OPTION (WITH_UNIT_TESTS "Compile MySQL with unit tests" ON)
MARK_AS_ADVANCED(CYBOZU)
+IF (WITHOUT_SERVER)
+ SET (SKIP_COMPONENTS "Server|IniFiles|SuportFiles|Readme")
+ELSE()
+ SET (SKIP_COMPONENTS "N-O-N-E")
+ENDIF()
+
OPTION(NOT_FOR_DISTRIBUTION "Allow linking with GPLv2-incompatible system libraries. Only set it you never plan to distribute the resulting binaries" OFF)
INCLUDE(check_compiler_flag)