summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorunknown <acurtis/antony@xiphis.org/ltantony.xiphis.org>2006-08-24 22:10:55 -0700
committerunknown <acurtis/antony@xiphis.org/ltantony.xiphis.org>2006-08-24 22:10:55 -0700
commitcf9d738b6214afe33389798bd196b0205f09b3b8 (patch)
tree10cf85c6fccc323cd58e0e82f80dbaf9a8ba5542 /CMakeLists.txt
parent4ec86b1c0453c18092a9f66292b19afbceadd9dc (diff)
downloadmariadb-git-cf9d738b6214afe33389798bd196b0205f09b3b8.tar.gz
fix for windows build
CMakeLists.txt: add for federated libmysqld/CMakeLists.txt: ha_heap.cc and ha_myisam.cc are removed add for federated sql/CMakeLists.txt: add for federated sql/handler.cc: fix for fussy compilers storage/heap/CMakeLists.txt: add ha_heap.cc storage/myisammrg/CMakeLists.txt: add ha_myisammrg.cc
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ec744e975c7..da528d5d293 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -140,6 +140,9 @@ ENDIF(WITH_CSV_STORAGE_ENGINE)
IF(WITH_EXAMPLE_STORAGE_ENGINE)
ADD_SUBDIRECTORY(storage/example)
ENDIF(WITH_EXAMPLE_STORAGE_ENGINE)
+IF(WITH_FEDERATED_STORAGE_ENGINE)
+ ADD_SUBDIRECTORY(storage/federated)
+ENDIF(WITH_FEDERATED_STORAGE_ENGINE)
IF(WITH_INNOBASE_STORAGE_ENGINE)
ADD_SUBDIRECTORY(storage/innobase)
ENDIF(WITH_INNOBASE_STORAGE_ENGINE)