summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authordf@pippilotta.erinye.com <>2007-05-02 19:21:50 +0200
committerdf@pippilotta.erinye.com <>2007-05-02 19:21:50 +0200
commit39e98943f99ba2d546c5c82fd2b20589b7698a47 (patch)
treed33afd9fd5e3fe03401ff5d91d1ea65be10f1414 /CMakeLists.txt
parent0db7e9c4f1af186dca44fc6ba1716b797df176bd (diff)
parent765b6f5572b96f7dd0f7301f92c3ebba18d48776 (diff)
downloadmariadb-git-39e98943f99ba2d546c5c82fd2b20589b7698a47.tar.gz
Merge dfischer@bk-internal.mysql.com:/home/bk/mysql-5.0-build
into pippilotta.erinye.com:/shared/home/df/mysql/build/mysql-5.0-build
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 68238ea157c..f5a1c0cfaba 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -120,6 +120,9 @@ IF(CMAKE_GENERATOR MATCHES "Visual Studio 7" OR
STRING(REPLACE "/MDd" "/MTd" CMAKE_CXX_FLAGS_DEBUG
${CMAKE_CXX_FLAGS_DEBUG})
+ # generate map files
+ SET(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} /MAP /MAPINFO:EXPORTS")
+
# remove support for Exception handling
STRING(REPLACE "/GX" "" CMAKE_CXX_FLAGS ${CMAKE_CXX_FLAGS})
STRING(REPLACE "/EHsc" "" CMAKE_CXX_FLAGS ${CMAKE_CXX_FLAGS})