summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHe Zhenxing <zhenxing.he@sun.com>2009-10-23 21:34:07 +0800
committerHe Zhenxing <zhenxing.he@sun.com>2009-10-23 21:34:07 +0800
commitce912c8ccf12d9a1c71e8adafb0e2c544bdc2efc (patch)
tree2d432790f3036c01c8e23aef82020f9c58c9a92b /CMakeLists.txt
parent6ae50d8aedbded8dcdc7504d116f25bcd02535ff (diff)
parenta02972d8206e1f1d01618ef065f47a32e1749ac7 (diff)
downloadmariadb-git-ce912c8ccf12d9a1c71e8adafb0e2c544bdc2efc.tar.gz
Auto merge 5.1-rep-semisync to 5.1-rep+2-delivery1
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7d91e39eb6d..e7d05f33ffa 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -276,6 +276,10 @@ FOREACH(DIR ${DYNAMIC_ENGINE_DIRECTORIES})
ADD_SUBDIRECTORY(${DIR})
ENDFOREACH(DIR ${DYNAMIC_ENGINE_DIRECTORIES})
+# Add subdirectories for semisync plugin
+IF(NOT WITHOUT_DYNAMIC_PLUGINS)
+ ADD_SUBDIRECTORY(plugin/semisync)
+ENDIF(NOT WITHOUT_DYNAMIC_PLUGINS)
# FIXME "debug" only needed if build type is "Debug", but
# CMAKE_BUILD_TYPE is not set during configure time.