summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMarko Mäkelä <marko.makela@mariadb.com>2019-05-03 20:14:09 +0300
committerMarko Mäkelä <marko.makela@mariadb.com>2019-05-03 20:14:09 +0300
commitb6f4cccd191f7d98306db9ebc6e8667ec9e1ec79 (patch)
treef530d85bd1ca8b3cb45f6b6d2b0e1e2ac6b24451 /CMakeLists.txt
parent779fb636daf4c127dbb90f75bab004ac1bbe12df (diff)
parentce195987c3c995470992f16ca7a985796d6b65a6 (diff)
downloadmariadb-git-b6f4cccd191f7d98306db9ebc6e8667ec9e1ec79.tar.gz
Merge 10.2 into 10.3
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 688e8ef2d38..6615106093d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -219,7 +219,7 @@ IF (WITH_UBSAN)
IF(SECURITY_HARDENED)
MESSAGE(FATAL_ERROR "WITH_UBSAN and SECURITY_HARDENED are mutually exclusive")
ENDIF()
- MY_CHECK_AND_SET_COMPILER_FLAG("-fsanitize=undefined" DEBUG RELWITHDEBINFO)
+ MY_CHECK_AND_SET_COMPILER_FLAG("-fsanitize=undefined -fno-sanitize=alignment" DEBUG RELWITHDEBINFO)
ENDIF()
IF(NOT WITH_TSAN)