summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorOleksandr Byelkin <sanja@mariadb.com>2018-06-23 09:47:18 +0200
committerOleksandr Byelkin <sanja@mariadb.com>2018-06-25 13:28:09 +0200
commit46fc864b90228e007e13fbd166674309d51bf955 (patch)
treec36654819914b9662db193a642feea71cc6a396e /CMakeLists.txt
parent88aaf590ac9fa8c8030a5831cebd867a7f35478f (diff)
downloadmariadb-git-46fc864b90228e007e13fbd166674309d51bf955.tar.gz
MDEV-16478: mysql_real_connect() from libmariadbd.so always crash
Returned accidentally removed undefinition of MYSQL_SERVER in net_serv.cc inside embedded server (embedded server uses real_net_read/write only as a client) Prevented attempt to clean up embedded server if it was not initialized
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 76b0817f8c7..d1595aa77b4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -398,6 +398,7 @@ IF(NOT WITHOUT_SERVER)
IF(WITH_EMBEDDED_SERVER)
ADD_SUBDIRECTORY(libmysqld)
ADD_SUBDIRECTORY(libmysqld/examples)
+ ADD_SUBDIRECTORY(unittest/embedded)
ENDIF(WITH_EMBEDDED_SERVER)
IF(WITH_WSREP)