summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVladislav Vaintroub <wlad@mariadb.com>2020-10-27 11:49:17 +0100
committerVladislav Vaintroub <wlad@mariadb.com>2020-12-15 12:27:13 +0100
commitac9c6f53a5e1d0637fb390f1cd7b44bd8c38d72e (patch)
tree7039d695de56675e91e6000a4cf742fe0924587e /CMakeLists.txt
parent74223c33d1aeffac28b155c59646dc3df58e33fb (diff)
downloadmariadb-git-ac9c6f53a5e1d0637fb390f1cd7b44bd8c38d72e.tar.gz
MDEV-24034 Policy CMP0075 is not set during compile
The policy is not set for 10.2 If it is set, CMake would complain about bundled zlib for which the policy is not set. Fix: - Set policy for 10.2 for the top level project. For 10.3+ it was already set - Cleanup zlib to remove unneeded stuff. It is an internal static library, it needs none of PROJECT, library versioning, RC file on Windows. The name of the library on Unix does not make any difference, since it is static and compiled in.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4734c6f7d5f..466b2a5bc3a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -37,6 +37,9 @@ ENDIF()
IF(POLICY CMP0054)
CMAKE_POLICY(SET CMP0054 NEW)
ENDIF()
+IF(POLICY CMP0075)
+ CMAKE_POLICY(SET CMP0075 NEW)
+ENDIF()
MESSAGE(STATUS "Running cmake version ${CMAKE_VERSION}")