summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSergei Golubchik <sergii@pisem.net>2014-03-27 22:26:58 +0100
committerSergei Golubchik <sergii@pisem.net>2014-03-27 22:26:58 +0100
commitcb67dcb6184535349ca4ff3d7c64eba9c63a0688 (patch)
tree10d38ccf7fe60d5ea5c866d37292833b77dfcdae /CMakeLists.txt
parent44002a34e680c79c01df879b540458c2885e97e8 (diff)
parentfaec0e2f4aecfc902e354ae7af991779d6bfc4a7 (diff)
downloadmariadb-git-cb67dcb6184535349ca4ff3d7c64eba9c63a0688.tar.gz
mysql-5.5.37 selective merge
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt17
1 files changed, 9 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f7035c54a08..794e0c44307 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,5 @@
-# Copyright (c) 2006, 2013, Oracle and/or its affiliates.
-# Copyright (c) 2008, 2013, Monty Program Ab
+# Copyright (c) 2006, 2014, Oracle and/or its affiliates.
+# Copyright (c) 2008, 2014, Monty Program Ab
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -329,14 +329,15 @@ IF(INSTALL_SYSCONFDIR)
SET(DEFAULT_SYSCONFDIR "${INSTALL_SYSCONFDIR}")
ENDIF()
-OPTION(TMPDIR
-"PATH to MySQL TMP dir. If unspecified, defaults to P_tmpdir in <stdio.h>" OFF)
-IF(TMPDIR)
+SET(TMPDIR ""
+ CACHE PATH
+ "PATH to MySQL TMP dir. Defaults to the P_tmpdir macro in <stdio.h>")
+IF(TMPDIR STREQUAL "")
+ # Do not quote it, to refer to the P_tmpdir macro.
+ SET(DEFAULT_TMPDIR "P_tmpdir")
+ELSE()
# Quote it, to make it a const char string.
SET(DEFAULT_TMPDIR "\"${TMPDIR}\"")
-ELSE()
- # Do not quote it, to refer to the P_tmpdir macro in <stdio.h>.
- SET(DEFAULT_TMPDIR "P_tmpdir")
ENDIF()
# Run platform tests