summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorunknown <df@pippilotta.erinye.com>2007-05-02 15:50:08 +0200
committerunknown <df@pippilotta.erinye.com>2007-05-02 15:50:08 +0200
commit11a630c4ca7099b8599e63b2f7928d8fac69e86b (patch)
tree295586b6b4b8efbda43f17aae9b6de432425015b /CMakeLists.txt
parent0d3c4483530469670b05acc77b853aad6b78a6e7 (diff)
downloadmariadb-git-11a630c4ca7099b8599e63b2f7928d8fac69e86b.tar.gz
generate map files on windows
CMakeLists.txt: Generate map files for executables
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3a286071bb0..6e6ac835b5d 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -116,6 +116,9 @@ IF(CMAKE_GENERATOR MATCHES "Visual Studio 7" OR
STRING(REPLACE "/MDd" "/MTd" CMAKE_CXX_FLAGS_DEBUG
${CMAKE_CXX_FLAGS_DEBUG})
+ # generate map files
+ SET(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} /MAP /MAPINFO:EXPORTS")
+
# remove support for Exception handling
STRING(REPLACE "/GX" "" CMAKE_CXX_FLAGS ${CMAKE_CXX_FLAGS})
STRING(REPLACE "/EHsc" "" CMAKE_CXX_FLAGS ${CMAKE_CXX_FLAGS})