summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVladislav Vaintroub <vvaintroub@linux-rbsx>2010-01-20 00:52:21 +0100
committerVladislav Vaintroub <vvaintroub@linux-rbsx>2010-01-20 00:52:21 +0100
commita71e4cf18e819fa99fdedf17ae1b070f62c401e0 (patch)
treee73bf16289b6e08db5b2b5c23042b8bf2136af5d /CMakeLists.txt
parent7753db1d17741050ed2b2dc450a83c5054ffb91a (diff)
downloadmariadb-git-a71e4cf18e819fa99fdedf17ae1b070f62c401e0.tar.gz
- another take on BUILD_CONFIG variable - use OPTION instead of SET for
boolean variables to ensure option is in cache. Also use documented CMAKE_USE_MAKE_RULES_OVERRIDE feature instead of INCLUDE. - remove superfluous tests in innobase's CMakeLists.txt
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 77cb30a8a40..d2f33bf6571 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -54,12 +54,14 @@ IF(WITH_DEBUG_FULL)
SET(WITH_DEBUG ON CACHE BOOL "Use DBUG")
ENDIF()
-PROJECT(MySQL)
-
IF(BUILD_CONFIG)
- INCLUDE(${CMAKE_SOURCE_DIR}/cmake/build_configurations/${BUILD_CONFIG}.cmake)
+ SET(CMAKE_USER_MAKE_RULES_OVERRIDE
+ ${CMAKE_SOURCE_DIR}/cmake/build_configurations/${BUILD_CONFIG}.cmake)
ENDIF()
+PROJECT(MySQL)
+
+
IF(CYGWIN)
SET(WIN32 0)
ENDIF()