summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHakan Kuecuekyilmaz <hakan@askmonty.org>2010-06-24 22:40:30 +0200
committerHakan Kuecuekyilmaz <hakan@askmonty.org>2010-06-24 22:40:30 +0200
commit4ee9e66d87cc9ee265b502f803c6884fa3f45940 (patch)
treed4e511782ae72ac7e0f678482f4d8d3f6ce03b4c /CMakeLists.txt
parent84074519a590c7843d49529b92ed557e5fa9cd63 (diff)
downloadmariadb-git-4ee9e66d87cc9ee265b502f803c6884fa3f45940.tar.gz
Make MariaDB compile with VS 2010
Most of the changes are backports from MySQL 5.5. Please note that the 64-bit build fails with VS 2010 and the 32-bit build has problems running mysql-test-run.pl. * Added files for compiling with VS 2010 and added them to Makefile.am. * ifdef'ed ETIMEDOUT, because it is defined by VS 2010 now * Removed not needed /MAP's from cmake files
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index db7415ed0e5..e998fe1825b 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -116,8 +116,7 @@ IF(MSVC)
STRING(REPLACE "/MDd" "/MTd" CMAKE_CXX_FLAGS_DEBUG ${CMAKE_CXX_FLAGS_DEBUG})
STRING(REPLACE "/MDd" "/MTd" CMAKE_CXX_FLAGS_DEBUG_INIT ${CMAKE_CXX_FLAGS_DEBUG_INIT})
- # generate map files, set stack size (see bug#20815)
- SET(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} /MAP /MAPINFO:EXPORTS")
+ # set stack size (see bug#20815)
SET(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} /STACK:1048576")
# remove support for Exception handling