summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSergei Golubchik <sergii@pisem.net>2011-12-14 10:53:32 +0100
committerSergei Golubchik <sergii@pisem.net>2011-12-14 10:53:32 +0100
commitdb8f698c8a03bcc920b9453f8822fbbd8ec7ea66 (patch)
tree3c12c81dfdf1ea5d2af805fb5f93daa0b45e408a /CMakeLists.txt
parent44d335b828440603353d8f1f4dfc6db2cf72ca8c (diff)
downloadmariadb-git-db8f698c8a03bcc920b9453f8822fbbd8ec7ea66.tar.gz
new configure option: NOT_FOR_DISTRIBUTION
fix safemalloc to compile w/o libbfd. CMakeLists.txt: NOT_FOR_DISTRIBUTION option cmake/readline.cmake: simplify libedit/readline detection. never use bundled libedit. use system readline v6 only if NOT_FOR_DISTRIBUTION=1 configure.cmake: use libbfd only if NOT_FOR_DISTRIBUTION=1 include/my_stacktrace.h: link with libbfd even w/o safemalloc.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 9 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d6cfd7fc288..b6f771544a7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -166,6 +166,7 @@ ENDIF()
OPTION (WITH_UNIT_TESTS "Compile MySQL with unit tests" ON)
MARK_AS_ADVANCED(CYBOZU BACKUP_TEST WITHOUT_SERVER DISABLE_SHARED)
+OPTION(NOT_FOR_DISTRIBUTION "Allow linking with GPLv2-incompatible system libraries. Only set it you never plan to distribute the resulting binaries" OFF)
OPTION(ENABLE_DEBUG_SYNC "Enable debug sync (debug builds only)" ON)
IF(ENABLE_DEBUG_SYNC)
@@ -264,9 +265,9 @@ MYSQL_CHECK_READLINE()
#
IF(MYSQL_MAINTAINER_MODE)
# Set compiler flags required under maintainer mode.
- MESSAGE(STATUS "C warning options: ${MY_MAINTAINER_C_WARNINGS}")
+ #MESSAGE(STATUS "C warning options: ${MY_MAINTAINER_C_WARNINGS}")
SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${MY_MAINTAINER_C_WARNINGS}")
- MESSAGE(STATUS "C++ warning options: ${MY_MAINTAINER_CXX_WARNINGS}")
+ #MESSAGE(STATUS "C++ warning options: ${MY_MAINTAINER_CXX_WARNINGS}")
SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${MY_MAINTAINER_CXX_WARNINGS}")
ENDIF()
@@ -392,3 +393,9 @@ IF(NOT INSTALL_LAYOUT MATCHES "RPM")
PATTERN "sp-imp-spec.txt" EXCLUDE
)
ENDIF()
+
+IF(NON_DISTRIBUTABLE_WARNING)
+ MESSAGE(WARNING "
+You have linked MariaDB with GPLv3 libraries! You may not distribute the resulting binary. If you do, you will put yourself into a legal problem with Free Software Foundation.")
+ENDIF()
+