summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authormysqlonarm <61234003+mysqlonarm@users.noreply.github.com>2020-06-01 14:04:06 +0530
committerGitHub <noreply@github.com>2020-06-01 11:34:06 +0300
commitdec3f8ca69e5eb19a4be7a175d3834874c4d880b (patch)
tree8e95e960ec07e5e1bce55ba421c2b54e234e7812 /CMakeLists.txt
parent6a6aa1c08977ed2ad2bf4a8ef88a44d9dbd69501 (diff)
downloadmariadb-git-dec3f8ca69e5eb19a4be7a175d3834874c4d880b.tar.gz
MDEV-22641: Provide SIMD optimized wrapper for zlib crc32() (#1558)
Existing implementation used my_checksum (from mysys) for calculating table checksum and binlog checksum. This implementation was optimized for powerpc only and lacked SIMD implementation for x86 (using clmul) and ARM (using ACLE) instead used zlib-crc32. mariabackup had its own copy of the crc32 implementation using hardware optimized implementation only for x86 and lagged hardware based implementation for powerpc and ARM. Patch helps unifies all such calls and help aggregate all of them using an unified interface my_checksum(). Said unification also enables hardware optimized calls for all architecture viz. x86, ARM, POWERPC. Default always fallback to zlib crc32. Thanks to Daniel Black for reviewing, fixing and testing PowerPC changes. Thanks to Marko and Daniel for early code feedback.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5d85d565e52..b170ecabef5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -170,7 +170,6 @@ INCLUDE(systemd)
INCLUDE(mysql_add_executable)
INCLUDE(symlinks)
INCLUDE(compile_flags)
-INCLUDE(crc32)
INCLUDE(pmem)
# Handle options