summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVicențiu Ciorbaru <vicentiu@mariadb.org>2017-09-19 12:43:02 +0300
committerVicențiu Ciorbaru <vicentiu@mariadb.org>2017-09-19 12:43:02 +0300
commit22c322c649d5a15e3bb731d6751a0d80c8ec23b0 (patch)
tree11073f6169c237da226a977736d234c7c7b5c163 /CMakeLists.txt
parent7d49aab32c3733f26cff8d83396a65bd120352e8 (diff)
parentec6042bda097fa53c43caf4a1acc32c5a77f6ed4 (diff)
downloadmariadb-git-22c322c649d5a15e3bb731d6751a0d80c8ec23b0.tar.gz
Merge branch '10.1' into 10.2
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b0cf68351b7..3c638cb2d41 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -465,6 +465,12 @@ ENDIF()
INCLUDE(CPack)
+IF(WIN32 AND SIGNCODE)
+ # Configure post-install script for authenticode signing
+ CONFIGURE_FILE(${PROJECT_SOURCE_DIR}/cmake/sign.cmake.in sign.cmake @ONLY)
+ INSTALL(SCRIPT ${PROJECT_BINARY_DIR}/sign.cmake)
+ENDIF()
+
IF(NON_DISTRIBUTABLE_WARNING)
MESSAGE(WARNING "
You have linked MariaDB with GPLv3 libraries! You may not distribute the resulting binary. If you do, you will put yourself into a legal problem with Free Software Foundation.")