summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSergei Golubchik <serg@mariadb.org>2017-08-09 18:23:04 +0200
committerSergei Golubchik <serg@mariadb.org>2017-08-14 19:45:58 +0200
commitc872b10022180602fbd5b2b0310b6d1e343dff5a (patch)
treebf899ad9e77c58b4efc4f2b73c3f1a4e0253fab5 /CMakeLists.txt
parentc9db190fed4e368201703e3d1031e16abfd61e45 (diff)
downloadmariadb-git-c872b10022180602fbd5b2b0310b6d1e343dff5a.tar.gz
don't install same files twice
CMakeLists.txt - merge mistake, apparently include/CMakeLists.txt - install from CMAKE_CURRENT_BINARY_DIR. Only install from CMAKE_CURRENT_SOURCE_DIR, if it's different from CMAKE_CURRENT_BINARY_DIR mysql-test/CMakeLists.txt - INSTALL_MYSQL_TEST() macro installs everything, no need to install mtr separately once again mysql-test/lib/My/SafeProcess/CMakeLists.txt MYSQL_ADD_EXECUTABLE includes INSTALL sql-bench/CMakeLists.txt list files explicitly. don't install garbage, don't process 'foo' and 'foo.sh' separately, it's only one file to install, not two.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ed80c5b8889..b0cf68351b7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -460,7 +460,6 @@ INSTALL_DOCUMENTATION(README.md CREDITS COPYING COPYING.thirdparty
# ${CMAKE_BINARY_DIR}/Docs/INFO_BIN)
IF(UNIX)
- INSTALL_DOCUMENTATION(Docs/INSTALL-BINARY COMPONENT Readme)
INSTALL_DOCUMENTATION(Docs/INSTALL-BINARY Docs/README-wsrep COMPONENT Readme)
ENDIF()