summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSergei Golubchik <serg@mariadb.org>2015-02-12 13:14:55 +0100
committerSergei Golubchik <serg@mariadb.org>2015-02-12 13:14:55 +0100
commit5dce6aa1fe36d315f17eb9f4a0f5be808805e94c (patch)
tree009d91ac356abbed8e8d68d4109823fa7c3f67c9 /CMakeLists.txt
parented839052d74847c39484eff18652e5c6ba270266 (diff)
parent2a1be9cdf81ca77253faaf0e2dfc1dca7f7702f5 (diff)
downloadmariadb-git-5dce6aa1fe36d315f17eb9f4a0f5be808805e94c.tar.gz
Merge remote-tracking branch 'bzr/5.5' into bb-5.5-merge
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 83b3a7e450d..c1ce1c55978 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -350,6 +350,11 @@ MYSQL_CHECK_READLINE()
CHECK_JEMALLOC()
+IF(CMAKE_CROSSCOMPILING)
+ SET(IMPORT_EXECUTABLES "IMPORTFILE-NOTFOUND" CACHE FILEPATH "Path to import_executables.cmake from a native build")
+ INCLUDE(${IMPORT_EXECUTABLES})
+ENDIF()
+
#
# Setup maintainer mode options by the end. Platform checks are
# not run with the warning options as to not perturb fragile checks