summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorunknown <df@pippilotta.erinye.com>2007-05-04 09:37:50 +0200
committerunknown <df@pippilotta.erinye.com>2007-05-04 09:37:50 +0200
commit6b7b95637a1cbe2ddd76b87017a9bdd434650073 (patch)
tree4be62b83005c4b89b811c908fae9befe168611f9 /CMakeLists.txt
parentad33a48afc21c7c89e7ea893ea826e305bd09258 (diff)
downloadmariadb-git-6b7b95637a1cbe2ddd76b87017a9bdd434650073.tar.gz
BUG#24732 manifest file was not included in VS2005 amd64 builds
CMakeLists.txt: BUG#24732 prevent VS2005 from overwriting our generated manifest
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f5a1c0cfaba..890ee2676e8 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -154,6 +154,11 @@ IF(EMBED_MANIFESTS)
# Disable automatic manifest generation.
STRING(REPLACE "/MANIFEST" "/MANIFEST:NO" CMAKE_EXE_LINKER_FLAGS
${CMAKE_EXE_LINKER_FLAGS})
+ # Explicitly disable it since it is the default for newer versions of VS
+ STRING(REGEX MATCH "MANIFEST:NO" tmp_manifest ${CMAKE_EXE_LINKER_FLAGS})
+ IF(NOT tmp_manifest)
+ SET(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} /MANIFEST:NO")
+ ENDIF(tmp_manifest)
# Set the processor architecture.
IF(CMAKE_GENERATOR MATCHES "Visual Studio 8 2005 Win64")
SET(PROCESSOR_ARCH "X64")