summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMarko Mäkelä <marko.makela@mariadb.com>2021-10-18 16:36:24 +0300
committerMarko Mäkelä <marko.makela@mariadb.com>2021-10-18 16:36:24 +0300
commit9c5835e067e99e1f85477f28d3bdc807537393a8 (patch)
tree644c828a4812ab1f0fffb3ada2deb5822997ce46 /CMakeLists.txt
parent78e023c2743c9b7fc17db31cc11524920b658075 (diff)
parent18eab4a83280049974265358b0d78389d05cd67b (diff)
downloadmariadb-git-9c5835e067e99e1f85477f28d3bdc807537393a8.tar.gz
Merge 10.5 into 10.6
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 00007f92f57..75fcb311ddd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -173,6 +173,10 @@ IF(DISABLE_SHARED)
SET(WITHOUT_DYNAMIC_PLUGINS 1)
ENDIF()
OPTION(ENABLED_PROFILING "Enable profiling" ON)
+OPTION(ENABLED_JSON_WRITER_CONSISTENCY_CHECKS "Enable Json_writer_object / Json_writer_array checking to produce consistent JSON output" OFF)
+IF(ENABLED_JSON_WRITER_CONSISTENCY_CHECKS)
+ ADD_DEFINITIONS(-DENABLED_JSON_WRITER_CONSISTENCY_CHECKS)
+ENDIF()
OPTION(WITHOUT_SERVER "Build only the client library and clients" OFF)
IF(UNIX)
OPTION(WITH_VALGRIND "Valgrind instrumentation" OFF)