summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorunknown <df@pippilotta.erinye.com>2007-07-19 23:06:34 +0200
committerunknown <df@pippilotta.erinye.com>2007-07-19 23:06:34 +0200
commitd9fda1cf9a8a460eb7cfb70615911580a429a280 (patch)
tree5d33aa92ae3706ae94d0da9d934f712abee800aa /CMakeLists.txt
parent9fa66ba423b776934513fd2a318a57ee16dc6bcf (diff)
downloadmariadb-git-d9fda1cf9a8a460eb7cfb70615911580a429a280.tar.gz
BUG#20815 Errno 12 on Windows after 197 connections
CMakeLists.txt: BUG#20815 Set stack size. This value is really supposed to be the linker's default. I'm not quite sure why we have to specify it manually too.
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d2a828c1843..cdd0cde8b8d 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -123,6 +123,9 @@ IF(CMAKE_GENERATOR MATCHES "Visual Studio 7" OR
# generate map files
SET(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} /MAP /MAPINFO:EXPORTS")
+ # set stack size (see bug#20815)
+ SET(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} /STACK:1048576")
+
# remove support for Exception handling
STRING(REPLACE "/GX" "" CMAKE_CXX_FLAGS ${CMAKE_CXX_FLAGS})
STRING(REPLACE "/EHsc" "" CMAKE_CXX_FLAGS ${CMAKE_CXX_FLAGS})