summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAjo Robert <ajo.robert@oracle.com>2016-01-07 14:36:19 +0530
committerAjo Robert <ajo.robert@oracle.com>2016-01-07 14:36:19 +0530
commit3d1306f7b74077cfa197c8fa23baeb96c535af67 (patch)
treed6c2dae346f0cbafed48ff2a04093f0fa654a99b /CMakeLists.txt
parent8c65e082f397a34cf393cfc6019daaa303ef5151 (diff)
downloadmariadb-git-3d1306f7b74077cfa197c8fa23baeb96c535af67.tar.gz
Bug#21770366 backport bug#21657078 to 5.5 and 5.6
Problem Statement ========= Fix various issues when building MySQL with Visual Studio 2015. Fix: ======= - Visual Studio 2015 adds support for timespec. Add check and related code to use this and only use our replacement if timespec is not defined. - Rename lfind/lsearch to my* to avoid redefinition problems. - Set default value for TMPDIR to "" on Windows as P_tmpdir no longer exists. - using VS definition of snprintf if available - tzname are now renamed to _tzname.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt15
1 files changed, 11 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 586119b2ffb..1abfa95f8b3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,4 +1,4 @@
-# Copyright (c) 2006, 2015, Oracle and/or its affiliates. All rights reserved.
+# Copyright (c) 2006, 2016, Oracle and/or its affiliates. All rights reserved.
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -328,9 +328,16 @@ IF(SYSCONFDIR)
SET(DEFAULT_SYSCONFDIR "${SYSCONFDIR}")
ENDIF()
-SET(TMPDIR "P_tmpdir"
- CACHE PATH
- "PATH to MySQL TMP dir. Defaults to the P_tmpdir macro in <stdio.h>")
+IF(WIN32) # P_tmpdir is not defined on Windows as of VS2015.
+ SET(TMPDIR "" # So we use empty path as default. In practice TMP/TEMP is used
+ CACHE PATH
+ "PATH to MySQL TMP dir")
+ELSE()
+ SET(TMPDIR "P_tmpdir"
+ CACHE PATH
+ "PATH to MySQL TMP dir. Defaults to the P_tmpdir macro in <stdio.h>")
+ENDIF()
+
IF(TMPDIR STREQUAL "P_tmpdir")
# Do not quote it, to refer to the P_tmpdir macro.
SET(DEFAULT_TMPDIR "P_tmpdir")