summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBjorn Munch <bjorn.munch@oracle.com>2012-07-19 12:57:36 +0200
committerBjorn Munch <bjorn.munch@oracle.com>2012-07-19 12:57:36 +0200
commit1a6ce811fdbb93c974ecd75e6951dca30bbc6262 (patch)
tree471fbcb1a5af0b2f7664afb9f4e19bd932eba2e9 /CMakeLists.txt
parent6ee1c030432f34cda52a5fb9c29f7852e46e834d (diff)
downloadmariadb-git-1a6ce811fdbb93c974ecd75e6951dca30bbc6262.tar.gz
Bug #14035452 - MODULARIZE MYSQL_CLIENT_TEST
Added new minimal client using same framework Added internal test using it Small changes to top level make/configure/cmake to have it built
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c30db2927d4..75927c40cae 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -310,3 +310,6 @@ IF(WITH_EMBEDDED_SERVER)
ADD_SUBDIRECTORY(libmysqld/examples)
ENDIF(WITH_EMBEDDED_SERVER)
ADD_SUBDIRECTORY(mysql-test/lib/My/SafeProcess)
+IF(EXISTS ${CMAKE_SOURCE_DIR}/internal/CMakeLists.txt)
+ ADD_SUBDIRECTORY(internal)
+ENDIF()