summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKent Boortz <kent.boortz@sun.com>2009-12-11 19:11:49 +0100
committerKent Boortz <kent.boortz@sun.com>2009-12-11 19:11:49 +0100
commit98f738b1986bc7a6f3755a30841c084f12e6e051 (patch)
treefa4d50aeac63425ff2aad97f9a2a3799faee5105 /CMakeLists.txt
parent088bac1a66a13fb5de09ceb9a7fd9672da784b9c (diff)
downloadmariadb-git-98f738b1986bc7a6f3755a30841c084f12e6e051.tar.gz
Define _WIN32_WINNT to the minimum supported Windows version, 0x0500 i.e
Windows 2000. Visual Studio 2003 and 2005 require _WIN32_WINNT >= 0x0500 (Win2000) for TryEnterCriticalSection.
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5705a2dfe57..bd597cf29c9 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -146,6 +146,7 @@ IF(MSVC)
ENDIF(MSVC)
ADD_DEFINITIONS("-D_WINDOWS -D__WIN__ -D_CRT_SECURE_NO_DEPRECATE")
+ADD_DEFINITIONS("-D_WIN32_WINNT=0x0500")
# This definition is necessary to work around a bug with Intellisense described
# here: http://tinyurl.com/2cb428. Syntax highlighting is important for proper