summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorunknown <iggy@alf.(none)>2008-02-27 16:17:05 -0500
committerunknown <iggy@alf.(none)>2008-02-27 16:17:05 -0500
commited4578c02e446254a5cd1bf7851ff95677068c54 (patch)
treee37ed94935e04c1e055ea6d4d23d5288f87daa4c /CMakeLists.txt
parent862c4750cd4e220b5c428c490fea2798878af092 (diff)
downloadmariadb-git-ed4578c02e446254a5cd1bf7851ff95677068c54.tar.gz
Bug #23839 Multiple declarations of macros
- Remove duplicate macro defintions. CMakeLists.txt: Bug #23839 Multiple declarations of macros - Make sure _WIN64 is defined for proper Intellisense functionality. include/config-win.h: Bug #23839 Multiple declarations of macros - Remove extra definitions. Use the my_global.h defines instead. include/my_global.h: Bug #23839 Multiple declarations of macros - Slight change to maintain current definitions for Windows.
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 27b2bf9b70e..55489da784c 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -125,6 +125,14 @@ ENDIF(CMAKE_GENERATOR MATCHES "Visual Studio 7" OR
ADD_DEFINITIONS("-D_WINDOWS -D__WIN__ -D_CRT_SECURE_NO_DEPRECATE")
+# This definition is necessary to work around a bug with Intellisense described
+# here: http://tinyurl.com/2cb428. Syntax highlighting is important for proper
+# debugger functionality.
+IF(CMAKE_SIZEOF_VOID_P MATCHES 8)
+ MESSAGE(STATUS "Detected 64-bit platform.")
+ ADD_DEFINITIONS("-D_WIN64")
+ENDIF(CMAKE_SIZEOF_VOID_P MATCHES 8)
+
IF(EMBED_MANIFESTS)
# Search for the tools (mt, makecat, signtool) necessary for embedding
# manifests and signing executables with the MySQL AB authenticode cert.