summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSergei Golubchik <serg@mariadb.org>2018-07-06 04:03:43 +0200
committerSergei Golubchik <serg@mariadb.org>2018-08-12 11:37:42 +0200
commit96b8909062c0b4df654f11057905b1e31398f88f (patch)
treef5b191ef5c9447edb61c5db0a2a848ad335b1c78 /CMakeLists.txt
parentaa19eda7dac2f91da76fa1783fe4bb860e59fd94 (diff)
downloadmariadb-git-96b8909062c0b4df654f11057905b1e31398f88f.tar.gz
MDEV-16662 CMake warnings: CMP0022
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 2 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5d95bb568cf..94e38658697 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,12 +14,10 @@
# along with this program; if not, write to the Free Software
# Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
-CMAKE_MINIMUM_REQUIRED(VERSION 2.8.3)
+CMAKE_MINIMUM_REQUIRED(VERSION 2.8.7)
-# explicitly set the policy to OLD
-# (cannot use NEW, not everyone is on cmake-2.8.12 yet)
IF(POLICY CMP0022)
- CMAKE_POLICY(SET CMP0022 OLD)
+ CMAKE_POLICY(SET CMP0022 NEW)
ENDIF()
# We use the LOCATION target property (CMP0026)