summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authormsvensson@pilot.blaudden <>2007-04-18 13:21:39 +0200
committermsvensson@pilot.blaudden <>2007-04-18 13:21:39 +0200
commit20e622dcf3d287cb8934ab7ad1d9a0cc90f88a45 (patch)
tree4317cddb056d39ce60584a2c016839216506b06b /CMakeLists.txt
parent1c5c12ac5e4147326ef516c50fb0320b4c9e85ef (diff)
downloadmariadb-git-20e622dcf3d287cb8934ab7ad1d9a0cc90f88a45.tar.gz
Bug#25452 mysql_upgrade access denied
- Improve mysql_upgrade and add comments describing it's logic - Don't look for mysql and mysqlcheck randomly, use dir where mysql_upgrade was started from - Don't look for mysql_fix_privilege_tables.sql randomly, compile in the mysql_fix_privilege_tables.sql file and use that to upgrade the system tables of MySQL - Check for any unexpected error returned from runnning the mysql_fix_privilege_tables SQL - Fix bug#26639, bug#24248 and bug#25405
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b458864c410..6615599cd4a 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -128,6 +128,7 @@ ADD_SUBDIRECTORY(dbug)
ADD_SUBDIRECTORY(strings)
ADD_SUBDIRECTORY(regex)
ADD_SUBDIRECTORY(mysys)
+ADD_SUBDIRECTORY(scripts)
ADD_SUBDIRECTORY(extra/yassl)
ADD_SUBDIRECTORY(extra/yassl/taocrypt)
ADD_SUBDIRECTORY(extra)