summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVladislav Vaintroub <wlad@sun.com>2010-06-21 13:39:30 +0200
committerVladislav Vaintroub <wlad@sun.com>2010-06-21 13:39:30 +0200
commit97d36ef532d4f0e9cd64eeb314167ff45a00ac6d (patch)
tree58ae60fc53279f63640fbfdbe29ce6e6b60ab3c8 /CMakeLists.txt
parente475440f1b2e8cee42b8594b4f957c0cc96bb118 (diff)
downloadmariadb-git-97d36ef532d4f0e9cd64eeb314167ff45a00ac6d.tar.gz
Bug#53593: Add some instrumentation to improve Valgrind sensitivity.
Implement WITH_VALGRIND for the CMake build.
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 536fae9f4b1..f4c7f552e93 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -115,6 +115,9 @@ OPTION(ENABLED_PROFILING "Enable profiling" ON)
OPTION(CYBOZU "" OFF)
OPTION(BACKUP_TEST "" OFF)
OPTION(WITHOUT_SERVER OFF)
+IF(UNIX)
+ OPTION(WITH_VALGRIND "Valgrind instrumentation" OFF)
+ENDIF()
OPTION (WITH_UNIT_TESTS "Compile MySQL with unit tests" ON)
MARK_AS_ADVANCED(CYBOZU BACKUP_TEST WITHOUT_SERVER DISABLE_SHARED)