summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorunknown <iggy@amd64.(none)>2007-06-01 16:48:23 -0400
committerunknown <iggy@amd64.(none)>2007-06-01 16:48:23 -0400
commit1a2869abe323f818936581be64c1ae1de0fdbfd1 (patch)
tree1ba19fcaca29cd12950988feeb7916a9567bc802 /CMakeLists.txt
parent7067af181c302574b90f7931ddb590300bff1667 (diff)
downloadmariadb-git-1a2869abe323f818936581be64c1ae1de0fdbfd1.tar.gz
Bug #24732 Executables do not include Vista manifests
- Cleanup typo. - Make sure to only embedded four part numberic version. CMakeLists.txt: Bug #24732 Executables do not include Vista manifests - Correct typo in manifest detection logic. win/create_manifest.js: Bug #24732 Executables do not include Vista manifests - Remove -* from the end of version string before embedding into manifest.
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 890ee2676e8..54df0befad9 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -158,7 +158,7 @@ IF(EMBED_MANIFESTS)
STRING(REGEX MATCH "MANIFEST:NO" tmp_manifest ${CMAKE_EXE_LINKER_FLAGS})
IF(NOT tmp_manifest)
SET(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} /MANIFEST:NO")
- ENDIF(tmp_manifest)
+ ENDIF(NOT tmp_manifest)
# Set the processor architecture.
IF(CMAKE_GENERATOR MATCHES "Visual Studio 8 2005 Win64")
SET(PROCESSOR_ARCH "X64")