summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGeorgi Kodinov <joro@sun.com>2009-05-27 18:14:09 +0300
committerGeorgi Kodinov <joro@sun.com>2009-05-27 18:14:09 +0300
commitd40826ce6b8af549f01fbeb4ab15faba85953957 (patch)
tree80f64731fb8db1f50d156ba60644db11c218b997 /CMakeLists.txt
parent13919e0c9fbd4f822de27dfcf68432b6b6ded60f (diff)
parent3b44d5526378a84768dbe54e77dd1e61a8e7bbd5 (diff)
downloadmariadb-git-d40826ce6b8af549f01fbeb4ab15faba85953957.tar.gz
merged 5.0-bugteam
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7c173c9cb49..e4dc16040a7 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -47,6 +47,10 @@ SET(WITH_MYISAMMRG_STORAGE_ENGINE TRUE)
ADD_DEFINITIONS(-DWITH_MYISAMMRG_STORAGE_ENGINE)
SET (mysql_plugin_defs "${mysql_plugin_defs},builtin_myisammrg_plugin")
+IF(WITH_COMMUNITY_FEATURES)
+ ADD_DEFINITIONS(-DENABLED_PROFILING -DCOMMUNITY_SERVER)
+ENDIF(WITH_COMMUNITY_FEATURES)
+
IF(WITH_ARCHIVE_STORAGE_ENGINE)
ADD_DEFINITIONS(-DWITH_ARCHIVE_STORAGE_ENGINE)
SET (mysql_plugin_defs "${mysql_plugin_defs},builtin_archive_plugin")