summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSergei Golubchik <sergii@pisem.net>2015-02-10 10:19:42 +0100
committerSergei Golubchik <sergii@pisem.net>2015-02-10 10:19:42 +0100
commit75884242abd855429fa17c5aa4ef8e7a76fd22fb (patch)
treeb64812b5dcb077e35f3be7281c3368d077c2c29c /CMakeLists.txt
parenta34fd50ce1c4385a7e63522d3d248fc3d417449b (diff)
downloadmariadb-git-75884242abd855429fa17c5aa4ef8e7a76fd22fb.tar.gz
restore a cross-compiling bit that was lost in a merge
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6bb269abe76..20191c0f154 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -350,6 +350,11 @@ MYSQL_CHECK_READLINE()
CHECK_JEMALLOC()
+IF(CMAKE_CROSSCOMPILING)
+ SET(IMPORT_EXECUTABLES "IMPORTFILE-NOTFOUND" CACHE FILEPATH "Path to import_executables.cmake from a native build")
+ INCLUDE(${IMPORT_EXECUTABLES})
+ENDIF()
+
#
# Setup maintainer mode options by the end. Platform checks are
# not run with the warning options as to not perturb fragile checks