summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorunknown <gkodinov/kgeorge@magare.gmz>2007-04-23 17:15:51 +0300
committerunknown <gkodinov/kgeorge@magare.gmz>2007-04-23 17:15:51 +0300
commitb570cee1152b61422b0e0bd3035194cdbb21ce5d (patch)
treee1e2c8962687ebeb74a223bd271b6c25ad1c8f36 /CMakeLists.txt
parent5b0ec8709ad4946260e257916a31d213b6168d26 (diff)
downloadmariadb-git-b570cee1152b61422b0e0bd3035194cdbb21ce5d.tar.gz
Bug #27811:
FORCE_INIT_OF_VARS was not defined for the debug builds on Windows. This caused LINT_INIT macro to be defined as NOP and this triggers false alarms about use of uninitialized with the runtime libs of some Visual Studio versions. Fixed by defining FORCE_INIT_OF_VARS to match the state of the Windows CMakeLists.txt: Bug #27811: added the missing build option mysql-test/r/windows.result: Bug #27811: test case mysql-test/t/windows.test: Bug #27811: test case
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3a286071bb0..b93b3e0db27 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -26,6 +26,10 @@ ADD_DEFINITIONS(-D WITH_MYISAM_STORAGE_ENGINE)
ADD_DEFINITIONS(-D CMAKE_BUILD)
ADD_DEFINITIONS(-D HAVE_YASSL)
+# Set debug options
+SET(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} -DFORCE_INIT_OF_VARS")
+SET(CMAKE_CXX_FLAGS_RELWITHDEBINFO "${CMAKE_CXX_FLAGS_RELWITHDEBINFO} -DFORCE_INIT_OF_VARS")
+
SET (mysql_plugin_defs "${mysql_plugin_defs},builtin_myisam_plugin")