summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSergei Golubchik <serg@mariadb.org>2019-03-16 19:37:44 +0100
committerSergei Golubchik <serg@mariadb.org>2019-03-27 22:51:37 +0100
commitb12f14965db9586e70109fe4cbf5dbd18bf2158d (patch)
treefb0cd937f5a4a45b41b1c8808dad5262ecb1935e /CMakeLists.txt
parentecc2711328e2e6e77758b9fe6c2a9892a2fe9192 (diff)
downloadmariadb-git-b12f14965db9586e70109fe4cbf5dbd18bf2158d.tar.gz
MDEV-7066 No Source RPMs ... (and so no "yum-builddep MariaDB-server" either)
automatic BuildRequires for source RPM: for every FILEPATH and "Have library XXX" cached variable, detect what rpm package it comes from and add it to the list of dependencies. That is, the source RPM will BuildRequire all those packages that were found by cmake when the source RPM was built. Presumably, our CMakeLists.txt won't check for libraries that aren't needed for a build. It supports libraries/executables/files found with FIND_LIBRARY FIND_FILE FIND_PROGRAM CHECK_LIBRARY_EXISTS
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3bfbcc4995d..54645e0b5c2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -499,6 +499,8 @@ IF(UNIX)
INSTALL_DOCUMENTATION(Docs/INSTALL-BINARY Docs/README-wsrep COMPONENT Readme)
ENDIF()
+INCLUDE(build_depends)
+
INCLUDE(CPack)
IF(WIN32 AND SIGNCODE)