summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVladislav Vaintroub <vvaintroub@mysql.com>2010-11-13 19:38:39 +0100
committerVladislav Vaintroub <vvaintroub@mysql.com>2010-11-13 19:38:39 +0100
commit8a9549434d48a4eabe43a081a9a895a8bff5a8a9 (patch)
treef9ecaa74685e238755a9d9a2fa6241ee4ad043e4 /CMakeLists.txt
parent9c70014e650e7c86762c2c000f978682cd52dd77 (diff)
downloadmariadb-git-8a9549434d48a4eabe43a081a9a895a8bff5a8a9.tar.gz
Bug#58178: "make package" is broken with cmake 2.8.3
Problem: with "make package" , many small packages are generated, one per CMake COMPONENT, instead of expected single package. This is due to the new (in cmake 2.8.3) component-based install for archive( e.g ZIP,TGZ ) CPack generators. See http://public.kitware.com/Bug/view.php?id=11452 for discussion. Fix: use CPACK_MONOLITHIC_INSTALL=1 to enforce single package. Reset this variable temporarily to 0 for MSI creation (MSI needs COMPONENTs)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 544c48f79f6..4078e520a08 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -331,6 +331,11 @@ ELSE()
SET(CPACK_GENERATOR "TGZ")
ENDIF()
ADD_SUBDIRECTORY(packaging/WiX)
+
+# Create a single package with "make package"
+# (see http://public.kitware.com/Bug/view.php?id=11452)
+SET(CPACK_MONOLITHIC_INSTALL 1 CACHE INTERNAL "")
+
INCLUDE(CPack)
IF(UNIX)
INSTALL(FILES Docs/mysql.info DESTINATION ${INSTALL_INFODIR} OPTIONAL)