summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEugene Kosov <claprix@yandex.ru>2019-03-16 21:06:04 +0300
committerSergey Vojtovich <svoj@mariadb.org>2019-05-03 18:54:12 +0400
commitbcc1359223c254e7649383c0993b6d27d5002c5d (patch)
tree0a04400062abf1ffa0306f714ff9de5f48ea0f2d /CMakeLists.txt
parent13d7c721a54ea777898cd0db9dce8ebc516a8af8 (diff)
downloadmariadb-git-bcc1359223c254e7649383c0993b6d27d5002c5d.tar.gz
MDEV-17702 fix unaligned access UB in sint4korr() and similar functions
Disable (hopefully temprorary) this check. Also add tests for some serialized functions.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 03ab7216bad..f2397d29968 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -217,7 +217,7 @@ IF (WITH_UBSAN)
IF(SECURITY_HARDENED)
MESSAGE(FATAL_ERROR "WITH_UBSAN and SECURITY_HARDENED are mutually exclusive")
ENDIF()
- MY_CHECK_AND_SET_COMPILER_FLAG("-fsanitize=undefined" DEBUG RELWITHDEBINFO)
+ MY_CHECK_AND_SET_COMPILER_FLAG("-fsanitize=undefined -fno-sanitize=alignment" DEBUG RELWITHDEBINFO)
ENDIF()