summaryrefslogtreecommitdiff
path: root/Docs/Makefile.am
diff options
context:
space:
mode:
authorunknown <jcole@tetra.spaceapes.com>2000-09-26 17:28:18 -0500
committerunknown <jcole@tetra.spaceapes.com>2000-09-26 17:28:18 -0500
commit32fc4416af3672098545f23dbcdb6da199e8bbc3 (patch)
tree732ee79accbc2f2be8993bdd11478fb9457f2b76 /Docs/Makefile.am
parent6cf0e5f9675a3d3fd0eb5bf91a592f2e64b67cde (diff)
downloadmariadb-git-32fc4416af3672098545f23dbcdb6da199e8bbc3.tar.gz
Docs/Makefile.am:
PDF Manual now has Indexes. Docs/manual.texi: Added stub and conditionals for removing GPL and LGPL from NuSphere manual. Docs/Makefile.am: PDF Manual now has Indexes Docs/manual.texi: Added stub and conditionals for removing GPL and LGPL from NuSphere manual.
Diffstat (limited to 'Docs/Makefile.am')
-rw-r--r--Docs/Makefile.am30
1 files changed, 18 insertions, 12 deletions
diff --git a/Docs/Makefile.am b/Docs/Makefile.am
index cd539277c70..090467e47cb 100644
--- a/Docs/Makefile.am
+++ b/Docs/Makefile.am
@@ -58,14 +58,18 @@ manual.html: manual.texi include.texi $(srcdir)/Support/texi2html
# Fix: add --output-comment with some interesting info?
# Fix: @image worked with a older version of pdftex.
+# Note: @image will work if we first convert all images to pdf ...
+# is that worth it?
# Comment: We need to run pdftex 2 times to get the cross references right.
manual.pdf: manual.texi
- cat manual.texi | sed -e 's|@image{[^}]*} *||g' > manual-tmp.texi; \
- pdftex --interaction=nonstopmode '\input manual-tmp.texi'; \
- pdftex --interaction=nonstopmode '\pdfcompresslevel=9' \
- '\input manual-tmp.texi'; \
- mv manual-tmp.pdf manual.pdf; \
- rm -f manual-tmp.* ; \
+ cat manual.texi | sed -e 's|@image{[^}]*} *||g' > manual-tmp.texi
+ pdftex --interaction=nonstopmode manual-tmp.texi
+ texindex manual-tmp.??
+ pdftex --interaction=nonstopmode manual-tmp.texi
+ texindex manual-tmp.??
+ pdftex --interaction=nonstopmode manual-tmp.texi
+ mv manual-tmp.pdf manual.pdf
+ rm -f manual-tmp.*
touch $@
# Target to produce NuSphere Manual
@@ -75,12 +79,14 @@ nusphere.pdf: manual.texi
-e 's/@end example/@end smallexample/g' \
-e 's/@c ifnusphere //g' \
-e 's|@image{[^}]*} *||g' \
- > manual-tmp.texi; \
- pdftex --interaction=nonstopmode '\input manual-tmp.texi'; \
- pdftex --interaction=nonstopmode '\pdfcompresslevel=9' \
- '\input manual-tmp.texi'; \
- mv manual-tmp.pdf nusphere.pdf; \
- rm -f manual-tmp.* ; \
+ > manual-tmp.texi
+ pdftex --interaction=nonstopmode manual-tmp.texi
+ texindex manual-tmp.??
+ pdftex --interaction=nonstopmode manual-tmp.texi
+ texindex manual-tmp.??
+ pdftex --interaction=nonstopmode manual-tmp.texi
+ mv manual-tmp.pdf nusphere.pdf
+ rm -f manual-tmp.*
touch $@
# The texi2dvi gives a lot of harmless errors. Just ignore them unless