summaryrefslogtreecommitdiff
path: root/Docs/Makefile.am
diff options
context:
space:
mode:
authorunknown <lenz@mysql.com>2005-04-19 17:18:56 +0200
committerunknown <lenz@mysql.com>2005-04-19 17:18:56 +0200
commit33ea3ff34525129f896ef431185cef60f259ee21 (patch)
tree880a2435dfe5482cb5bdfb287417601d8ea5600e /Docs/Makefile.am
parent254dfb2be0075b15af30778b51321f784bf45ef5 (diff)
parent1f1a579aa929cf7f0dd0870557e7e62d9e60b2d2 (diff)
downloadmariadb-git-33ea3ff34525129f896ef431185cef60f259ee21.tar.gz
- manual merge
sql/share/Makefile.am: Auto merged
Diffstat (limited to 'Docs/Makefile.am')
-rw-r--r--Docs/Makefile.am34
1 files changed, 23 insertions, 11 deletions
diff --git a/Docs/Makefile.am b/Docs/Makefile.am
index 92f3c56a504..6f8c51e79f0 100644
--- a/Docs/Makefile.am
+++ b/Docs/Makefile.am
@@ -1,13 +1,18 @@
-# Normally you do not need to remake the files here. But if you want
-# to you will need the GNU TeX-info utilities. To make a Postscript
-# files you also need TeX and dvips. To make the PDF file you will
-# need pdftex. We use the teTeX distribution for all of these.
-
-# We avoid default automake rules because of problems with .dvi file
-# and BSD makes
-
-# If you know how to fix any of this more elegantly please mail
-# docs@mysql.com
+# Copyright (C) 2000 MySQL AB & MySQL Finland AB & TCX DataKonsult AB
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
noinst_SCRIPTS = Support/generate-text-files.pl
@@ -15,9 +20,16 @@ EXTRA_DIST = $(noinst_SCRIPTS) mysql.info INSTALL-BINARY
all: txt_files
-txt_files: ../INSTALL-SOURCE ../COPYING ../INSTALL-WIN-SOURCE ../EXCEPTIONS-CLIENT \
+txt_files: ../INSTALL-SOURCE ../INSTALL-WIN-SOURCE ../EXCEPTIONS-CLIENT \
INSTALL-BINARY ../support-files/MacOSX/ReadMe.txt
+# make sure that "make install" installs the info page, too
+# automake only seems to take care of this automatically,
+# if we're building the info page from texi directly.
+install-data-hook: mysql.info
+ $(mkinstalldirs) $(DESTDIR)$(infodir)
+ $(INSTALL_DATA) $(srcdir)/mysql.info $(DESTDIR)$(infodir)
+
CLEAN_FILES: $(txt_files)
touch $(txt_files)