summaryrefslogtreecommitdiff
path: root/Docs/Makefile.am
diff options
context:
space:
mode:
authorunknown <kent/mysqldev@mysql.com/production.mysql.com>2008-04-08 11:44:18 +0200
committerunknown <kent/mysqldev@mysql.com/production.mysql.com>2008-04-08 11:44:18 +0200
commit1d5f5887ec388cc2ad459a48d44628237ef8973f (patch)
treeb921e6478aa47283773e1793dd4c8546377eb0bd /Docs/Makefile.am
parent9fd89afca04400812a8fec6b1802bf60518bd2ac (diff)
downloadmariadb-git-1d5f5887ec388cc2ad459a48d44628237ef8973f.tar.gz
Makefile.am:
Add ChangeLog if it exists - Removed separate 'normal+rowrepl' test run, not needed any longer - Removed separate 'rpl' test run, included in main test run already - Renamed some test "comments", to use similar naming style - Limited one of the Cluster test runs to 'ndb' and 'rpl_ndb' suites - Reordered test runs, to be aligned with Windows test runs mysql.spec.sh: - No longer including the "Example" storage engine - Added to configure "--without-ENGINE" if not to compile engine as plugin Docs/Makefile.am: Add ChangeLog if it exists Makefile.am: - Removed separate 'normal+rowrepl' test run, not needed any longer - Removed separate 'rpl' test run, included in main test run already - Renamed some test "comments", to use similar naming style - Limited one of the Cluster test runs to 'ndb' and 'rpl_ndb' suites - Reordered test runs, to be aligned with Windows test runs support-files/mysql.spec.sh: - No longer including the "Example" storage engine - Added to configure "--without-ENGINE" if not to compile engine as plugin
Diffstat (limited to 'Docs/Makefile.am')
-rw-r--r--Docs/Makefile.am19
1 files changed, 16 insertions, 3 deletions
diff --git a/Docs/Makefile.am b/Docs/Makefile.am
index 629618609a3..24f921a4877 100644
--- a/Docs/Makefile.am
+++ b/Docs/Makefile.am
@@ -19,11 +19,24 @@ EXTRA_DIST = mysql.info INSTALL-BINARY @extra_docs@
# automake only seems to take care of this automatically,
# if we're building the info page from texi directly.
install-data-hook: $(srcdir)/mysql.info
- $(mkinstalldirs) $(DESTDIR)$(infodir)
- $(INSTALL_DATA) $(srcdir)/mysql.info $(DESTDIR)$(infodir)
+ if test `basename $(prefix)` = "mysql" ; then \
+ $(mkinstalldirs) $(DESTDIR)$(prefix)/docs ; \
+ $(INSTALL_DATA) $(srcdir)/mysql.info $(DESTDIR)$(prefix)/docs ; \
+ test ! -f $(top_srcdir)/ChangeLog || $(INSTALL_DATA) $(top_srcdir)/ChangeLog $(DESTDIR)$(prefix)/docs ; \
+ else \
+ $(mkinstalldirs) $(DESTDIR)$(infodir) $(DESTDIR)$(pkgdatadir) ; \
+ $(INSTALL_DATA) $(srcdir)/mysql.info $(DESTDIR)$(infodir) ; \
+ test ! -f $(top_srcdir)/ChangeLog || $(INSTALL_DATA) $(top_srcdir)/ChangeLog $(DESTDIR)$(pkgdatadir) ; \
+ fi
uninstall-local:
- @RM@ -f $(DESTDIR)$(infodir)/mysql.info
+ if test `basename $(prefix)` = "mysql" ; then \
+ @RM@ -f $(DESTDIR)$(prefix)/docs/mysql.info ; \
+ @RM@ -f $(DESTDIR)$(prefix)/docs/ChangeLog ; \
+ else \
+ @RM@ -f $(DESTDIR)$(infodir)/mysql.info ; \
+ @RM@ -f $(DESTDIR)$(pkgdatadir)/ChangeLog ; \
+ fi
# Don't update the files from bitkeeper
%::SCCS/s.%